• das is bei mir nur einmal gekommen, als ich das form leer abgeschickt habe, wollte testen, ob wirklich eine validation dahinter liegt..


    hat schon jemand das mit nmap gemacht? bei mir wirft er nur fehler:


    ====
    Starting Nmap 5.51 ( http://nmap.org ) at 2012-03-22 20:10 Westeuropäische Normalzeit
    NSE: Loaded 57 scripts for scanning.
    Initiating Ping Scan at 20:10
    Scanning 128.130.60.30 [4 ports]
    WARNING: Using raw sockets because ppp0 is not an ethernet device. This probably won't work on Windows.


    pcap_open_live(ppp0, 100, 0, 2) FAILED. Reported error: Error opening adapter: Das System kann das angegebene Gerät nicht finden. (20). Will wait 5 seconds then retry.
    pcap_open_live(ppp0, 100, 0, 2) FAILED. Reported error: Error opening adapter: Das System kann das angegebene Gerät nicht finden. (20). Will wait 25 seconds then retry.
    Call to pcap_open_live() failed three times. There are several possible reasons for this, depending on your operating system:
    LINUX: If you are getting Socket type not supported, try modprobe af_packet or recompile your kernel with PACKET enabled.
    *BSD: If you are getting device not configured, you need to recompile your kernel with Berkeley Packet Filter support. If you are getting No such file or directory, try creating the device (eg cd /dev; MAKEDEV <device>; or use mknod).
    *WINDOWS: Nmap only supports ethernet interfaces on Windows for most operations because Microsoft disabled raw sockets as of Windows XP SP2. Depending on the reason for this error, it is possible that the --unprivileged command-line argument will help.
    SOLARIS: If you are trying to scan localhost or the address of an interface and are getting '/dev/lo0: No such file or directory' or 'lo0: No DLPI device found', complain to Sun. I don't think Solaris can support advanced localhost scans. You can probably use "-Pn -sT localhost" though.


    QUITTING!
    ====
    als befehl probiert hab ich:
    nmap -p 10001 -T4 -A -v 128.130.60.30
    nmap -p 10001 -T4 -A -v 128.130.60.30:10001
    nmap -p 10001 -T4 -A -v 128.130.60.30 -p 10001


    was mach ich falsch?

  • meine theorie ist ja, dass genau das ist was wir auch ergoogeln sollen... aber hab auch schon probiert und hatte auch so ne nette zeile: appears to be down.
    bei nmap gibts paar nette befehle in der hilfe...
    bin aber noch am anfang am werkeln :-) und noch total relaxt :-)

  • noch was kommt mir komisch vor: es heißt, wir sollen username und password des imap-accounts auslesen. laut rfc gibts dafür das LOGIN command, bloß im dump find ich das nirgends. ich finde das OK, das CAPABILITY und danach LOGGED IN. bloß kein login. irgendwelche hinweise?

  • noch was kommt mir komisch vor: es heißt, wir sollen username und password des imap-accounts auslesen. laut rfc gibts dafür das LOGIN command, bloß im dump find ich das nirgends. ich finde das OK, das CAPABILITY und danach LOGGED IN. bloß kein login. irgendwelche hinweise?


    es gibt mehrere möglichkeiten, lass dir den stream am besten schön mit wireshark anzeigen, dann siehst, dass vor LOGGED IN noch eine message gesandt wird

  • damit hab ich mich noch nicht beschäftigt, aber mit den ersten 2 fragestellungen ... gibt ein nettes handbuch im netz, dass die befehle bisserl mehr erklärt als in der hilfe :-)
    mit dem shark muss ich mich noch beschäftigen...

  • es gibt mehrere möglichkeiten, lass dir den stream am besten schön mit wireshark anzeigen, dann siehst, dass vor LOGGED IN noch eine message gesandt wird



    ja, der gedanke is mir schon gekommen. in der angabe gibts ja den verweis auf das plain authentication. das hab ich schon gefunden, weiß nur grad nicht wie ich das lesen soll. ist das irgendwie verschlüsselt? im rfc steht nix über verschlüsselung, und ich hab hier nur einen string der verdächtig nach hash-code aussieht

  • ja, der gedanke is mir schon gekommen. in der angabe gibts ja den verweis auf das plain authentication. das hab ich schon gefunden, weiß nur grad nicht wie ich das lesen soll. ist das irgendwie verschlüsselt? im rfc steht nix über verschlüsselung, und ich hab hier nur einen string der verdächtig nach hash-code aussieht


    base64...

    "The quieter you become, the more you are able to hear."
    -------------------------------------------------------------------------------------

  • kurze frage, könnt ihr euch via "ssh bandit" einloggen? bei mir akzeptiert er nämlich das von der lva bekommene passwort nicht.


    Bei mir funktioniert das Passwort von der LVA auch nicht! Gehört das schon zur Aufgabenstellung, dass man es schafft sich einzuloggen? Falls ja, dann will ich dass wissen. Vielleicht könnt ihr mir weiterhelfen! danke.

  • Bei mir funktioniert das Passwort von der LVA auch nicht! Gehört das schon zur Aufgabenstellung, dass man es schafft sich einzuloggen? Falls ja, dann will ich dass wissen. Vielleicht könnt ihr mir weiterhelfen! danke.


    Nein, das Passwort sollte eigentlich funktionieren. Hast du den richtigen Port benutzt (10001)?

  • nmap -p 10001 -T4 -A -v 128.130.60.30
    was mach ich falsch?


    Du sollst nicht bandit selbst scannen, sondern das Netzwerk, an das er angehängt ist. Schau dir mal mit dem Programm ifconfig die Adresse des Interfaces eth0 an, damit du weißt, welches Netz du scannen musst.


    Tipp: ifconfig ist nicht in deiner PATH drinnen, aber es ist auf dem System vorhanden.

    ~~ Ondra „Ravu al Hemio“ Hošek
    I know what PC LOAD LETTER means


    Tutor außer Dienst · OOP · OS · PK · PP

  • Du sollst nicht bandit selbst scannen, sondern das Netzwerk, an das er angehängt ist. Schau dir mal mit dem Programm ifconfig die Adresse des Interfaces eth0 an, damit du weißt, welches Netz du scannen musst.


    Tipp: ifconfig ist nicht in deiner PATH drinnen, aber es ist auf dem System vorhanden.


    thx hatte gestern den wald vor lauter bäume nicht gesehen ... dann wars klar nach dem Tipp :-)

  • Bei mir funktioniert das einloggen nur mit windows und Putty, über das terminal (osx) funktionierts nicht. kA warum


    Bei mir geht's... OS X Snow Leopard, OpenSSH_5.2p1 mit OpenSSL 0.9.8r, Terminal 2.1.2 (273.1), Befehl ssh -p 10001 inetsec081@inetsec.iseclab.org.


    OS X hat bekanntlich eine ziemlich unterschiedliche Belegung der Sonderzeichen auf der Tastatur; vielleicht liegt's daran? Falls du im Kennwort Zeichen außerhalb des Intervalls [U+0020, U+007E] verwendest, kann das auch wegen problematischer Unicode-Übertragung und -Übersetzung schieflaufen.

    ~~ Ondra „Ravu al Hemio“ Hošek
    I know what PC LOAD LETTER means


    Tutor außer Dienst · OOP · OS · PK · PP

    Edited 2 times, last by Ravu al Hemio: Automatic link parser, I hate you. ().

  • so irgendwie seh ich grad nur noch bäume und keinen wald... von eth0 wissen wir welche IP für nmap... nun hänge ich an task1 (secure manner) etwas fest... ich weiß durch nmap ja welche ports belegt sind (da ist z.b. ssl aufgelistet)... hab inzwischen schon etliche funktionen von nmap ausprobiert ...

  • Da ist Vorwissen gefragt: HTTP gibt es auch über SSL bzw. TLS getunnelt; diese Form heißt HTTPS. Das übliche HTTP läuft auf Port 80, und die Frage ist, welche Nummer der HTTPS-Port hat.

    ~~ Ondra „Ravu al Hemio“ Hošek
    I know what PC LOAD LETTER means


    Tutor außer Dienst · OOP · OS · PK · PP

    Edited once, last by Ravu al Hemio ().