Apache2 unter Ubuntu per SSH konfigurieren

  • Servus!


    Ich muss ich auf einem vorkonfiguriertem Ubuntu 8.04 Server mit lampp per SSH einige Webapplikationen installieren... jetzt komm ich damit aber noch nicht wirklich zurecht.


    SSH login haut hin, ich lande in meinem home-verzeichnis. Das Apache DocumentRoot dürfte wohl unter var/www/ liegen und der apache2 daemon läuft...


    --> jetzt meine etwas blöden fragen: Wie kann ich per IP Adreses (hab nur die, die ich für den ssh login benutze) auf das documentroot zugreifen, sodass ich eben die index.html in /var/www betrachten kann...


    check's leider noch nicht ganz ab


    thx4hints
    Fugo

  • meisens einfach nur ip in den browser eingeben.
    ansonsten sieh die mal die files in /etc/apache2/sites-enabled an vie die hosts konfiguriert sind. kann sein, dass der server nur für einen bestimmten domainnamen konfiguriert ist.
    wenn da so was steht wie:
    <VirtualHost example.com:80>
    werden nur requests für example.com akzeptiert.

    "All through my life I've had this strange unaccountable feeling that something was going on in the world, something big, even sinister, and no one would tell me what it was."
    "No," said the old man, "that's just perfectly normal paranoia. Everyone in the Universe has that."

    &#128513;&#128514;&#128515;&#128516;&#128517;&#128518;&#128519;&#128520;&#128521;&#128522;&#128523;&#128524;&#128525;&#128526;&#128527;&#128528;&#128530;&#128531;&#128532;&#128534;&#128536;&#128538;&#128540;&#128542;&#128544;&#128545;&#128546;&#128547;&#128549;&#128552;&#128553;&#128554;&#128555;&#128557;&#128560;&#128561;&#128562;&#128563;&#128565;&#128566;&#128567;

  • Ich versteh leider nicht ganz was du willst. Aber ich vermute mal du willst die seite jetzt über deinen Internet Explorer o.ä aufrufen?


    Wenn du die index.html in das richtige Verzeichnis kopiert hast (was mit /var/www eigentlich stimmen sollte) dann brauchst du die IP nur in deinem Browser eingeben. Sprich: http:\\die-ip-des-servers


    Dann sollte eigentlich die index.html aufgerufen und angezeigt werden.

  • jop, so hätt' ich das auch verstanden... geht aber nicht :-) ... mit der ip kommt leider gar nix...


    in der sites-enabled default steht nur der gesamte 80er port, daher sollte es ja eigentlich klappen... ich werd mich mal an den Admin richten -> wollte noch warten da ich nicht wusste, ob's da nicht doch einen gaaaanz einfachen "kniff" gibt ;-)

  • eventuell blockt da die firewall etwas ab. sollte eigentlich nicht sein, dass der 80er port gesperrt ist, den admin fragen kann ja nicht schaden.
    blöde frage: läuft der apache überhaupt?
    ansonsten kannst du ja probieren, dich mit ssh -X einzuloggen und einen browser direkt am server zu starten - falls einer installiert ist. wenn dann noch nix kommt, hat's wirklich was gröberes

    "All through my life I've had this strange unaccountable feeling that something was going on in the world, something big, even sinister, and no one would tell me what it was."
    "No," said the old man, "that's just perfectly normal paranoia. Everyone in the Universe has that."

    &#128513;&#128514;&#128515;&#128516;&#128517;&#128518;&#128519;&#128520;&#128521;&#128522;&#128523;&#128524;&#128525;&#128526;&#128527;&#128528;&#128530;&#128531;&#128532;&#128534;&#128536;&#128538;&#128540;&#128542;&#128544;&#128545;&#128546;&#128547;&#128549;&#128552;&#128553;&#128554;&#128555;&#128557;&#128560;&#128561;&#128562;&#128563;&#128565;&#128566;&#128567;

  • Quote from sutupud

    blöde frage: läuft der apache überhaupt?


    So blöd find ich die Frage gar nicht ;-) ... aber: ja, er läuft


    im Anhang die Ausgabe von netstat - scheint eh zu passen, oder?


    Werd' jetzt mal nachfragen...

  • Jetzt funktionniert soweit alles... fast:


    --> Beim Mailformular krieg' ich den Fehler, dass die mail-Funktion nicht initialisiert werden kann -> muss da der port freigeschalten werden (auch port 25?) oder liegt's an einer php.ini Einstellung?

  • --> Beim Mailformular krieg' ich den Fehler, dass die mail-Funktion nicht initialisiert werden kann -> muss da der port freigeschalten werden (auch port 25?) oder liegt's an einer php.ini Einstellung?

    Ich vermute, das Problem liegt daran, dass du entweder einen lokalen MTA (Postfix oder so) brauchst, der die Mails entgegennimmt und weiterleitet, oder php.ini-Einstellungen, die festlegen, welcher SMTP-Server verwendet werden soll.